Quick links: Content - sections - sub sections
EN FR
Quick Search Advanced search
 
Page

  [Opened] Configuration jelix

Bonjour, j'ai un petit problème. j'ai suivi la guide de configuration sur la doc concernant la configuration serveur. mais je ne peux pas spécifier le document root. alors je decide de passer au second solution. le problème c'est que les fichiers css et js ne charge pas. et aussi j'utilise url_engine significant mais ça ne marche pas. Les dossiers :

intranet -> //tous les dossiers classique de l'appli(modules , www , etc)
lib
temp
index.php // le fichier dans le dossier www

contenu du index.php

require ('intranet/application.init.php');
require (JELIX_LIB_CORE_PATH.'request/jClassicRequest.class.php');
checkAppOpened();
jApp::loadConfig('index/config.ini.php');
jApp::setCoord(new jCoordinator());
jApp::coord()->process(new jClassicRequest());

application.ini.php

require (__DIR__.'/../lib/jelix/init.php');

jApp::initPaths(
    __DIR__.'/',
    __DIR__.'/www/'
);
jApp::setTempBasePath(realpath(__DIR__.'/../temp/intranet/').'/');

projet.xml

<directories>
        <config>./var/config/</config>
        <log>./var/log/</log>
        <var>./var/</var>
        <www>../</www>
        <temp>../temp/intranet/</temp>
    </directories>  

Merci

  [Opened] Configuration jelix

Bonjour,

désolé pour le retard de la réponse.

Il semble que tu as oublié de déplacer tout les fichiers qu'il y a dans intranet/www/ vers la racine de ton projet, donc au même niveau que index.php. En fait tu ne devrais plus avoir de répertoire intranet/www.

Du coup dans ton application.init.php tu devrais avoir :

jApp::initPaths(
    __DIR__.'/',
    __DIR__.'/../'
);

  [Opened] Configuration jelix

Bonjour, ah ok!! du coup j'ai une autre question, comment faire pour les caractères speciaux(éàè..)? dans la template c'est déjà en UTF-8 mais je crois que c'est du HTML 4 comme ceci:

<meta content="text/html; charset=UTF-8" http-equiv="content-type"/>

alors que celui du HTML 5 est

<meta charset="utf-8"/>

Merci.

  [Opened] Configuration jelix

Je ne comprend pas la question. Quel est le problème ? Dans n'importe quel fichier, tu met tout en UTF-8. En ce qui concerne la balise meta, tu ne t'en occupes pas. C'est l'objet réponse HTML qui la met. jResponseHtml génère des entêtes HTML5, mais si tu veux du HTML4, il faut utiliser jResponseHtml4 : mettre html = jResponseHtml4 dans la section responses de la config.

Si tu as des soucis avec les infos récupérés de ta base, il faut ajouter force_encoding=on dans ton profil de connexion.

  [Opened] Configuration jelix

Désolé pour le retard , mais c'est résolu

  [Opened] Re: Configuration jelix

capital one login

 
Page
  1. Re: Configuration jelix