Quick links: Content - sections - sub sections
EN FR
Quick Search Advanced search
 
Page

  [Opened] Problème installation de jCommuntity 1.3

Bonjour,

Je teste l'environnement de jelix 1.7.4 avec le module jcommunity.

J'utilise la base de données postgresql et à l'installation du module, j'ai eu une erreur de syntaxe dans le script sql dans le fichier install.pgsql.sql où il manque une virgule à la fin de la première contrainte.

Après rectification, j'ai relancé l'installation et j'ai l'erreur suivante : [error] An error occured during the installation of the module jcommunity: Erreur dans la requête (ERROR: type "serial" does not exist(ALTER TABLE "community_users" ALTER COLUMN "id" TYPE serial))

La table est bien créée mais l'installation a échoué.

Cordialement

Denis

  [Opened] Problème installation de jCommuntity 1.3

Bonjour,

je confirme la virgule manquante, je vais corriger ça, merci smile

Pour le reste, quelle version de postgresql utilises-tu ? (je viens de tester sur pgsql 10 et 9.5, j'ai pas le souci)

  [Opened] Problème installation de jCommuntity 1.3

En fait, le problème se situerait plutôt dans jDaoDbMapper, vu que l'erreur est sur un alter table.

Je vais retester tout ça.

  [Opened] Re: Problème installation de jCommuntity 1.3

Bonjour Laurent,

J'utilise une version 11 de postgresql...

J'ai quelques soucis avec la version 1.7 depuis qu'elle existe. Jamais réussi à la faire fonctionner avec jcommunity et interface administrateur.

J'ai une grosse application que je réécris sous une version jelix 1.6.x et je voudrais en profiter pour passer en version 1.7.x J'ai essayé la migration mais le résultat est pas terrible; trop d'erreurs

À bientôt Denis

  [Opened] Problème installation de jCommuntity 1.3

J'ai vu d'où venait le problème pour l'installation, c'est dans Jelix. Je vais corriger ça.

Et je vais consolider jCommunity pour Jelix 1.7. En ce moment j'utilise jCommunity dans une appli qui est encore avec Jelix 1.6, avec des daos redéfinis etc, du coup il y a à priori des régression auxquelles je n'ai pas été confronté.

 
Page
  1. Problème installation de jCommuntity 1.3