Quick links: Content - sections - sub sections
EN FR
Quick Search Advanced search
 
Page

  [Opened] jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Bonjour, J'utilise jelix 1.6 et lors de la création des DAO, avec comme base PostGreSQL, la ligne de commande : "php cmd.php createdao monmodule matable madao" me renvoi toujours l'erreur : "[erreur:405] jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré"

Pourtant, dans un controller, avec utilisation de : $cnx = jDb::getConnection(); $result = $cnx->query("SELECT * FROM ma_table");

me renvoie des résultats sur une base en postgresql. Donc, aucun problème avec l'extension postgres. Environnement de dev : php7.2, postgresql 12

Pour info : j'ai déjà utilisé jelix 1.3 (avec php5) avec postgres il y a pas mal de temps mais aucun souci de ce genre. Est-ce que j'ai loupé un config?

Merci,

  [Opened] jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Bonjour,

Il s'agit probablement d'un problème de configuration PHP. Si tu es sur linux notament, il y a un php.ini pour PHP-FPM (ou le module PHP pour Apache), et un php.ini pour la version ligne de commande de PHP (PHP-CLI). Il semble que l'extension postgresql soit activée pour PHP-FPM, mais pas pour PHP-CLI.

Quel système d'exploitation utilises-tu ?

  [Opened] Re: jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Meric pour la réponse. Je suis sous ubuntu 18.04 LTS. Quels sont les démarches à faire? je suis à l'aise sous Linux donc aucun souci. Merci,

  [Opened] Re: jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Re,

La configuration php-cli pour l'extension postgresql est Ok. Sinon, un autre problème surgit lors du "php cmd.php createdao mon_module ma_table mon_dao"

[error:403] Erreur dans la requête (ERREUR: la colonne pg_class.relhaspkey n'existe pas LINE 1: SELECT pg_class.oid, pg_class.relhaspkey, pg_class.relhasind...

^(SELECT pg_class.oid, pg_class.relhaspkey, pg_class.relhasindex FROM pg_class WHERE relname = 'ma_table'))

C'est un table basique sans relation avec uniquement un identifiant ID en clé primaire.

Merci,

  [Opened] Re: jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Re-bonjour,

Apparemment, le "createdao" marche avec postgresql 9.6, ce qui n'est pas le cas pour la version 12 (Erreur : "ERREUR: la colonne pg_class.relhaspkey n'existe pas LINE 1: SELECT pg_class.oid, pg_class.relhaspkey,pg_class.relhasinde...). Pas encore testé avec la version 10 ou 11. Juste pour info, à moins j'ai oublié quelques paramétrages. Cordialement,

  [Opened] jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Est ce que la version de Jelix est la dernière 1.6 ? En Janvier, j'ai corrigé des incompatibilités avec Postgresql 12. Il faut donc au moins la 1.6.26. Mettre à jour à 1.6.29. Si c'est déjà le cas, alors il y a encore probablement un souci d'incompatibilité. Merci alors d'ouvrir un ticket sur github, en indiquant ce qui a été fait pour provoquer le bug.

  [Opened] Re: jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré

Re,

Effectivement, j'ai la version 1.6.16, mais en changeant vers 1.6.29, tout est nickel. Je vais faire un upgrade vers la dernière version étant donné que mon appli risque de s'agrandir et durer dans le temps! smile En tout cas, merci pour le support.

 
Page
  1. Re: jDb : l'extension posgresql n'est pas installée dans php pour le driver jDb configuré