Quick links: Content - sections - sub sections
EN FR
Quick Search Advanced search
 
Page

  [Opened] Problème avec jauth

Bonjour,

Je ne comprends pas cette erreur dans l'utilisation d'un script en mode console

J'utilise Jelix 1.7.4

$ php console.php technique:creerjeu
PHP Fatal error:  Uncaught Error: Call to a member function getPlugin() on null in .../vendor/jelix/jelix/lib/jelix/auth/jAuth.class.php:60
Stack trace:
#0 .../vendor/jelix/jelix/lib/jelix/auth/jAuth.class.php(155): jAuth::loadConfig()
#1 .../vendor/jelix/jelix/lib/jelix/auth/jAuth.class.php(204): jAuth::getDriver()
#2 .../tools/modules/outils/classes/OutilsJeux.class.php(71): jAuth::getUser()
#3 .../tools/modules/outils/classes/OutilsJeux.class.php(365): OutilsJeux->CreeLogin()
#4 .../admin/modules/technique/Scripts/CreationJeu.php(56): OutilsJeux->CreationMembre()
#5 .../admin/modules/technique/Scripts/CreerJeu.php(27): include('/...')
#6 .../vendor/symfony/console/Command/Command.php(255): SeoProject\Technique\Scripts\C in .../vendor/jelix/jelix/lib/jelix/auth/jAuth.class.php on line 60

Cordialement

  [Opened] Problème avec jauth

Bonjour,

je vois le problème. je vais le corriger.

  [Opened] Problème avec jauth

Salut Laurent,

9a ne marche pas avec Jcommunity car c'est ce module qui était installé auparavant. Je l'ai "déconfuguré" pour activer jauth. Même erreurs.

À bientôt

  [Opened] Problème avec jauth

rien à voir avec jCommunity ou jauth. Le problème se situe dans "l'environnement d'execution" de console.php, où il n'y a pas de coordinateur d'instancié, d'où l'erreur. J'ai corrigé ça. Utilise la version dev-jelix-1.7.x dans ton composer.json, en attendant que je sorte une 1.7.6 (sortie imminente)

  [Opened] Problème avec jauth

Bonjour Laurent, Merci pour ta réponse J'ai essayé de réinstaller avec composer mais j'ai des problèmes de dépendances avec composer-plugin-api et jelix/composer-module-setup

Mon composer.json

,
    "minimum-stability": "dev",
    "require": {
        "jelix/jelix": "dev-jelix-1.7.x",
        "jelix/jcommunity-module": "^1.3",
        "bozhinov/pchart": "^2.2",
        "jelix/tcpdf-module": "^1.7",
        "composer-plugin-api":"^2.0"
    },
    "require-dev": {
        "composer/composer": "^2.0"
    }

Retour de l’exécution

Problem 1
    - The requested package composer-plugin-api ^2.0 exists as composer-plugin-api[1.1.0] but these are rejected by your constraint.
  Problem 2
    - jelix/composer-module-setup 1.0.0 requires composer-plugin-api ^2.0 -> no matching package found.
    - jelix/jelix dev-jelix-1.7.x requires jelix/composer-module-setup ^1.0.0 -> satisfiable by jelix/composer-module-setup[1.0.0].
    - Installation request for jelix/jelix dev-jelix-1.7.x -> satisfiable by jelix/jelix[dev-jelix-1.7.x].
Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

A+

  [Opened] Problème avec jauth

J'ai utilisé ton composer.json, je n'ai pas eu de problème une fois que j'ai mis à jour Composer à sa dernière version.

Maintenant, je pense que les paquets composer/composer et composer-plugin-api sont inutiles dans ton composer.json.

  [Opened] Problème avec jauth

Re-salut Laurent,

Bonne idée la mise à jour de composer ça marche. (passé à la version 2) Je verrais lundi pour les modifications. Je te tiens au courant.

Bon week-end et merci

Cordialement

  [Opened] Problème avec jauth

Bonjour,

Ok pour l'utilisation de jauth avec des scripts

Merci, je peux avancer

Cordialement

 
Page
  1. Problème avec jauth